Instalacion moodle 3.x bypass para la version del dbms

Posted: 12th March 2017 by Jak in moodle, PHP
Tags: ,

Queremos instalar moodle pero tenemos una version mas reciente del dbms por ejemplo de mysq y la instalacion no puede terminar si no se cumplen los requisitos.

Una de las formas es hacer un bypass rapido, claro con las consecuencias que esto puede tener, si la version instalada es mas reciente no hay tanto problema.

Editamos el archivo moodle/lib/enviromentlib.php metodo environment_check_database y simplemente hacemos que el resultado sea true


/// And finally compare them, saving results
if (version_compare($current_version, $needed_version, '>=')) {
$result->setStatus(true);
} else {
$result->setStatus(false);
}
$result->setStatus(true); //JKF

Share